Prototype: cf_version_minimum(string)

Return type: boolean

Description: Returns true if local CFEngine version is newer than or equal to specified string.

Arguments:

  • string: string, in the range: .*

Example:

bundle agent __main__
{
  reports:
    "This will be skipped on older versions"
      if => cf_version_minimum("3.15");
    "This will be skipped on newer or equal versions"
      unless => cf_version_minimum("3.15");
}

Output:

R: This will be skipped on older versions

See also: cf_version_maximum(), cf_version_after(), cf_version_before(), cf_version_at(), cf_version_between().

History:

  • Introduced in 3.16.0